Question Detail

I am trying to run my Flutter Application in simulator but terminal gives me error

No connected devices.

I have searched for this issue then it says Flutter requires a minimum Xcode version of 9.0.0.

when i try to update y Xcode Apple Store says Xcode can’t be installed on “Macintosh HD” because macOS version 10.13.6 or later is required.

how can i update MacOS version?


Thread Reply

Anonymous

- 11 months ago

To download update you can go on official Apple website where everything can soleve and download what you want

Hemant Sharma

- 11 months ago

You have to upgrade your MacOs for How to upgrade Mac Os you have to go on Apple Official site and login with your Apple ID and find How to upgrade tab.

or you can direct go on below link and login to your Apple ID and find Upgrade button when you click on Upgrade button it will ask to launch Apple Store. Then simply press download 

It will take some time because of very big size file.

Finally You have updated your Mac Oprating System Update

Hemant Sharma

- 11 months ago

You have to upgrade your MacOs for How to upgrade Mac Os you have to go on Apple Official site and login with your Apple ID and find How to upgrade tab.

or you can direct go on below link and login to your Apple ID and find Upgrade button when you click on Upgrade button it will ask to launch Apple Store. Then simply press download 

It will take some time because of very big size file.

Finally You have updated your Mac Oprating System Update